Ubuntu编译安装LNMP,渡劫指南之PHP

1、通过宝塔国际版一键编译安装PHP 7.4 日志错误如下

检查是否使用 LIBXML 支持构建…是

检查 libxml-2.0 >= 2.7.6… 是

检查 OpenSSL 支持…是的

检查 Kerberos 支持…否

检查是否使用系统默认密码列表而不是硬编码值…否

检查 openssl >= 1.0.1… 否

配置:错误:未满足软件包要求(openssl >= 1.0.1):

找不到包“openssl”

如果您考虑调整 PKG_CONFIG_PATH 环境变量

以非标准前缀安装的软件。

或者,您可以设置环境变量 OPENSSL_CFLAGS

和 OPENSSL_LIBS 以避免调用 pkg-config。

有关更多详细信息,请参见 pkg-config 手册页。

make: *** 没有指定目标,也没有找到 makefile。停止。

make: *** 没有使目标“安装”的规则。停止。

==================================================== ======

cmake: /usr/local/lib/libcurl.so.4: 没有可用的版本信息(cmake 需要)

Ubuntu 20.04.3 LTS

图片[1]-Ubuntu编译安装LNMP,渡劫指南之PHP-itdog

2、根据提示安装openssl

sudo apt-get install openssl
sudo apt-get install libssl-dev
图片[2]-Ubuntu编译安装LNMP,渡劫指南之PHP-itdog

3、安装完成后,再次编译安装PHP 7.4没有报错,大功告成!

图片[3]-Ubuntu编译安装LNMP,渡劫指南之PHP-itdog



© 版权声明
THE END
原创不易,且珍惜。
点赞6赞赏 分享
评论 抢沙发
头像
欢迎留下宝贵见解!
提交
头像

昵称

取消
昵称表情代码图片