Ubuntu编译安装LNMP,渡劫指南之Nginx

我在宝塔面板上使用一键编译安卓LNMP环境,没多久提示安装完成,但实际却检测不到安装了LNMP任何一个组件,通过查看执行日志,发现安装过程中有报错,提示让去宝塔论坛反馈。

1、日志报错关键字

checking for zlib library … not found

2、根据提示应该是我的zlib库有问题,然后了解到安装zlib要求有ruby,且在ubuntu软件源里zlib和zlib-devel叫做zlib1g、zlib1g.dev

3、因此想安装zlib库需要在控制台中执行以下三条命令

sudo apt-get install ruby
sudo apt-get install zlib1g
sudo apt-get install zlib1g.dev

 4、不幸的是,我执行第三条命令又出现了意外

正在读取软件包列表… 完成
正在分析软件包的依赖关系树
正在读取状态信息… 完成
注意,根据正则表达式 ‘zlib1g.dev’ 选中了 ‘zlib1g-dev’
有一些软件包无法被安装。如果您用的是 unstable 发行版,这也许是
因为系统无法达到您要求的状态造成的。该版本中可能会有一些您需要的软件
包尚未被创建或是它们已被从新到(Incoming)目录移出。
下列信息可能会对解决问题有所帮助:

下列软件包有未满足的依赖关系:
zlib1g-dev : 依赖: zlib1g (= 1:1.2.11.dfsg-2ubuntu1) 但是 1:1.2.11.dfsg-2ubuntu1.2 正要被安装
E: 无法修正错误,因为您要求某些软件包保持现状,就是它们破坏了软件包间的依赖关系。

图片[1]-Ubuntu编译安装LNMP,渡劫指南之Nginx-itdog

5、看起来是zlib1g.dev与zlib1g的版本发生了冲突。按道理这种基础冲突不应该发生的,然后我想起了自己关闭了Ubuntu的更新。

稍微调整一下更新策略,并保障软件源里只有官方源。

图片[2]-Ubuntu编译安装LNMP,渡劫指南之Nginx-itdog
图片[3]-Ubuntu编译安装LNMP,渡劫指南之Nginx-itdog

所以这个故事告诉我们,萌新不要添加任何官网自带之外的源。

6、接着打开控制台,输入命令

sudo apt-get update

 7、更新完,再次安装zlib1g.dev

sudo apt-get install zlib1g.dev

8、至此终于安装成功,重新回到宝塔面板上,重新选择编译安装Ngix,大功告成!




© 版权声明
THE END
原创不易,且珍惜。
点赞12赞赏 分享
评论 抢沙发
头像
欢迎留下宝贵见解!
提交
头像

昵称

取消
昵称表情代码图片