安卓手机,通过Magisk(面具)安装EdXposed框架

最近看到别人给手机QQ和微信装了插件能实现很多额外功能觉得挺有意思打算试一试,但是安装这些插件发现都需要EdXposed框架。

我手机是淘宝找人root的,root完只给我装了Magisk(面具),当时店家想给我装EdXposed框架来着但一直没装上所以就放弃了

自己研究了一下安装步骤理论上是非常简单的。

1、打开Magisk(面具)

图片[1]-安卓手机,通过Magisk(面具)安装EdXposed框架-itdog

2、切换到模块页面,然后搜索Riru

图片[2]-安卓手机,通过Magisk(面具)安装EdXposed框架-itdog

3、先安装好Riru核心,再安装Riru-EdXposed

图片[3]-安卓手机,通过Magisk(面具)安装EdXposed框架-itdog
图片[4]-安卓手机,通过Magisk(面具)安装EdXposed框架-itdog

4、安装EdXposed管理界面

图片[5]-安卓手机,通过Magisk(面具)安装EdXposed框架-itdog

突发问题

1、自己手机上的 Magisk(面具) 默认源搜不出来所有需要的模块,想再添加些源进去,但又不知道哪里找地址

2、Riru核心与 Riru-EdXposed 冲突,根本没法同时安装。这问题经过搜索很多人都反应是Riru版本与 Riru-EdXposed 版本不兼容导致的,但我自己反复测试了好多个不同的Riru版本都未能解决。

3、 EdXposed管理界面是.apk文件, Magisk(面具) 只能装模块,所以这个.apk文件还得自己找。

针对上述遇到的困难,首先我放弃了在 Magisk(面具) 模块列表搜索安装的方式,我选择直接到作者Github上自己找。.APK文件同样也在Github上找到了。至于版本冲突的问题,同样在Github上看到了作者给其它网友的解答,通过安装Riru v25.4.4版本最终成功的让 Riru核心与 Riru-EdXposed 共存。

图片[6]-安卓手机,通过Magisk(面具)安装EdXposed框架-itdog

Github地址




© 版权声明
THE END
原创不易,且珍惜。
点赞4赞赏 分享
评论 共33条
头像
欢迎留下宝贵见解!
提交
头像

昵称

取消
昵称表情代码图片
    • 头像oilpot0